WordPress Version 5.5 Broke Your Site?

9th September 2020

Why WordPress Version 5.5 Broke Your Site

WordPress version 5.5 released on the 11th of August 2020 and broke many sites, potentially including yours.

This is because WordPress for the longest time used jQuery version 1.12.4, a version of the library released in 2016 which supports Internet Explorer 6, 7 and 8.

This version of jQuery that WordPress uses has now been upgraded to version 1.9+.

The issue arises because all of the themes and plugins for WordPress have been created to rely on the same version of jQuery as WordPress so they are compatible with the WordPress core, however all of a sudden they are no longer compatible, causing your site to break.

How can I fix my site?

The WordPress team of course predicted this outcome for many sites and have ahead of time created and released a plugin of their own to help sites by enabling a jQuery migration script which will enable the older version of jQuery and therefore resolve the compatibility issues with the themes and plugins on your site.

The plugin is called Enable jQuery Migrate Helper and can be found on the official WordPress plugin marketplace here: https://wordpress.org/plugins/enable-jquery-migrate-helper/

WordPress do state however that the "This plugin serves as a temporary solution, enabling the migration script for your site to give your plugin and theme authors some more time to update, and test, their code". So this is no permanent fix.

The only permanent fix for this is waiting for plugin and theme authors to release up to date versions and then for you to update them on your site as WordPress states.

Or if your site is majorly broken and the jQuery Migrate Helper does not resolve your issues, backdate to a previous version of your site and wait for the plugin and theme updates to release.

Categories